<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<title>Classic Reviews: Mechwarrior Dark Age by WizKids &#8211; Armchair Dragoons</title>
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Armchair Dragoons &raquo; Feed" href="https://www.armchairdragoons.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Armchair Dragoons &raquo; Comments Feed" href="https://www.armchairdragoons.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Armchair Dragoons &raquo; Classic Reviews: Mechwarrior Dark Age by WizKids Comments Feed" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.armchairdragoons.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sby_styles-css'  href='https://www.armchairdragoons.com/wp-content/plugins/feeds-for-youtube/css/sb-youtube.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.armchairdragoons.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://www.armchairdragoons.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='cool-tag-cloud-css'  href='https://www.armchairdragoons.com/wp-content/plugins/cool-tag-cloud/inc/cool-tag-cloud.css?ver=2.23' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://www.armchairdragoons.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='ssp-recent-episodes-css'  href='https://www.armchairdragoons.com/wp-content/plugins/seriously-simple-podcasting/assets/css/recent-episodes.css?ver=2.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.armchairdragoons.com/wp-content/themes/bamChild/assets/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='bam-style-css'  href='https://www.armchairdragoons.com/wp-content/themes/bamChild/style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='bam-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100i%2C200i%2C300i%2C400i%2C500i%2C600i%2C700i%2C800i%2C900i|Roboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100i%2C200i%2C300i%2C400i%2C500i%2C600i%2C700i%2C800i%2C900i%26subset%3Dlatin' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.armchairdragoons.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.13' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.armchairdragoons.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.6' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210219' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-177141667-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-177141667-1", {"anonymize_ip":true});
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/countdown-timer/js/webtoolkit.sprintf.js?ver=3.0.7' id='webkit_sprintf-js'></script>
<link rel="https://api.w.org/" href="https://www.armchairdragoons.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.armchairdragoons.com/wp-json/wp/v2/posts/8625" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.armchairdragoons.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.armchairdragoons.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<meta name="generator" content="Seriously Simple Podcasting 2.6.2" />
<link rel="canonical" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/" />
<link rel='shortlink' href='https://wp.me/pae4WL-2f7' />
<link rel="alternate" type="application/json+oembed" href="https://www.armchairdragoons.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.armchairdragoons.com%2Farticles%2Freviews%2Fclassic-reviews-mechwarrior-dark-age-by-wizkids%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.armchairdragoons.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.armchairdragoons.com%2Farticles%2Freviews%2Fclassic-reviews-mechwarrior-dark-age-by-wizkids%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.29.0" />
<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.armchairdragoons.com/feed/podcast" />

<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.armchairdragoons.com/?wordfence_lh=1&hid=A1B6487D6AD6A2AF415DF00EB11E7339');
</script><style type='text/css'>img#wpstats{display:none}</style>
				<style type="text/css">
					.site-title,
			.site-description {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
				display: none;
			}
				</style>
					<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Classic Reviews: Mechwarrior Dark Age by WizKids" />
<meta property="og:url" content="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/" />
<meta property="og:description" content="Michael Eckenfels, 8 April 2021 Having been a huge BattleTech nut back in the 1980&#8217;s (and owning most of the boxed sets for the game to this day), I jumped at the chance to take a look at the…" />
<meta property="article:published_time" content="2021-04-08T13:41:23+00:00" />
<meta property="article:modified_time" content="2021-04-08T13:44:49+00:00" />
<meta property="og:site_name" content="Armchair Dragoons" />
<meta property="og:image" content="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Splash.png?fit=500%2C400&amp;ssl=1" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="CR-MWDA-Splash" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@ADragoons" />
<meta name="twitter:site" content="@ADragoons" />
<meta name="twitter:text:title" content="Classic Reviews: Mechwarrior Dark Age by WizKids" />
<meta name="twitter:image" content="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Splash.png?fit=500%2C400&#038;ssl=1&#038;w=640" />
<meta name="twitter:image:alt" content="CR-MWDA-Splash" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/02/cropped-ACD-Counter.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/02/cropped-ACD-Counter.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/02/cropped-ACD-Counter.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/02/cropped-ACD-Counter.jpg?fit=270%2C270&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				a:hover {
	background-color: #FFFF99;
	text-decoration: underline;
}
ul li{
	line-height: 140%;
}			</style>
		
		<style type="text/css" id="theme-custom-css">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</style>

	</head>

<body class="post-template-default single single-post postid-8625 single-format-standard wp-custom-logo boxed-layout right-sidebar separate-containers">



<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
<div id="topbar" class="bam-topbar clearfix">

    <div class="container">

                    <span class="bam-date">April 8, 2021</span>
        
        
        
<div class="bam-topbar-social colored">

    
        
                    <span class="bam-social-icon">
                                    <a href="https://www.facebook.com/ArmchairDragoons/" class="bam-social-link facebook" target="_blank" title="Facebook">
                        <i class="fa fa-facebook"></i>
                    </a>
                            </span>
                
    
        
                    <span class="bam-social-icon">
                                    <a href="https://www.youtube.com/channel/UCJnWABRqXg1Eiteb36WJfew" class="bam-social-link youtube" target="_blank" title="Youtube">
                        <i class="fa fa-youtube-play"></i>
                    </a>
                            </span>
                
    
        
                    <span class="bam-social-icon">
                                    <a href="https://twitter.com/ADragoons" class="bam-social-link twitter" target="_blank" title="Twitter">
                        <i class="fa fa-twitter"></i>
                    </a>
                            </span>
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                
    
        
                    <span class="bam-social-icon">
                                    <a href="feed://armchairdragoons.com/feed/" class="bam-social-link rss" target="_blank" title="RSS">
                        <i class="fa fa-rss"></i>
                    </a>
                            </span>
                
    
        
                
    
</div><!-- .bam-social-media -->
    </div>

</div>
	


<header id="masthead" class="site-header default-style">

    
    

<div id="site-header-inner" class="clearfix container center-logo">

    <div class="site-branding">
    <div class="site-branding-inner">

                    <div class="site-logo-image"><a href="https://www.armchairdragoons.com/" class="custom-logo-link" rel="home"><img width="900" height="120" src="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?fit=900%2C120&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="DragoonsLogoHEADER-3" data-attachment-id="6561" data-permalink="https://www.armchairdragoons.com/dragoonslogoheader-3/" data-orig-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?fit=900%2C120&amp;ssl=1" data-orig-size="900,120" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DragoonsLogoHEADER-3" data-image-description="" data-medium-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?fit=300%2C40&amp;ssl=1" data-large-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?fit=700%2C93&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?w=900&amp;ssl=1 900w, https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?resize=300%2C40&amp;ssl=1 300w, https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?resize=700%2C93&amp;ssl=1 700w, https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?resize=768%2C102&amp;ssl=1 768w, https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?resize=150%2C20&amp;ssl=1 150w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-lazy-src="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2020/12/DragoonsLogoHEADER-3.png?fit=900%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>
        
        <div class="site-branding-text">
                            <p class="site-title"><a href="https://www.armchairdragoons.com/" rel="home">Armchair Dragoons</a></p>
                                <p class="site-description">The Regiment of Strategy Gaming</p>
                    </div><!-- .site-branding-text -->

    </div><!-- .site-branding-inner -->
</div><!-- .site-branding -->
        
</div><!-- #site-header-inner -->



<nav id="site-navigation" class="main-navigation">

    <div id="site-navigation-inner" class="align-center">
        
        <div class="menu-pages-container"><ul id="primary-menu" class="menu"><li id="menu-item-8201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8201"><a href="https://www.armchairdragoons.com/connections/">Connections Online</a></li>
<li id="menu-item-7131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7131"><a href="http://patreon.com/armchairdragoons">* Patreon *</a></li>
<li id="menu-item-561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-561"><a href="https://www.armchairdragoons.com/podcast/">Podcast</a></li>
<li id="menu-item-470" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470"><a href="https://www.armchairdragoons.com/forum/">Forum</a></li>
<li id="menu-item-8221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-8221"><a href="https://www.armchairdragoons.com">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-3504" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3504"><a href="https://www.armchairdragoons.com/dragoontv/">Our Video Channels</a></li>
	<li id="menu-item-3246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3246"><a href="https://www.armchairdragoons.com/wargame-network/">Wargame Network ~ Our Friends!</a></li>
</ul>
</li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30"><a href="https://www.armchairdragoons.com/about/">About &#038; References</a>
<ul class="sub-menu">
	<li id="menu-item-38" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38"><a href="https://www.armchairdragoons.com/armchair-dragoons-archives/">Article Archives</a></li>
	<li id="menu-item-8203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8203"><a href="https://www.armchairdragoons.com/wargaming-terms/">Wargaming Terms</a></li>
	<li id="menu-item-8205" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8205"><a href="https://www.armchairdragoons.com/research-bibliography/">Research Bibliography</a></li>
	<li id="menu-item-418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-418"><a href="https://www.cafepress.com/armchairdragoons">Swag</a></li>
</ul>
</li>
</ul></div>
        <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"><i class="fa fa-bars"></i>Menu</button>
        
    </div><!-- .container -->
    
</nav><!-- #site-navigation -->
<div class="mobile-dropdown">
    <nav class="mobile-navigation">
        <div class="menu-pages-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8201"><a href="https://www.armchairdragoons.com/connections/">Connections Online</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7131"><a href="http://patreon.com/armchairdragoons">* Patreon *</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-561"><a href="https://www.armchairdragoons.com/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470"><a href="https://www.armchairdragoons.com/forum/">Forum</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-8221"><a href="https://www.armchairdragoons.com">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3504"><a href="https://www.armchairdragoons.com/dragoontv/">Our Video Channels</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3246"><a href="https://www.armchairdragoons.com/wargame-network/">Wargame Network ~ Our Friends!</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30"><a href="https://www.armchairdragoons.com/about/">About &#038; References</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38"><a href="https://www.armchairdragoons.com/armchair-dragoons-archives/">Article Archives</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8203"><a href="https://www.armchairdragoons.com/wargaming-terms/">Wargaming Terms</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8205"><a href="https://www.armchairdragoons.com/research-bibliography/">Research Bibliography</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-418"><a href="https://www.cafepress.com/armchairdragoons">Swag</a></li>
</ul>
</li>
</ul></div>    </nav>
</div>

    
         
</header><!-- #masthead -->


	
	<div id="content" class="site-content">
		<div class="container">

	
	<div id="primary" class="content-area">

		
		<main id="main" class="site-main">

			
			
<article id="post-8625" class="bam-single-post post-8625 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-classic-reviews">
	
	
	<div class="category-list">
		<span class="cat-links"><a href="https://www.armchairdragoons.com/category/articles/reviews/" rel="category tag">Reviews</a></span>	</div><!-- .category-list -->

	<header class="entry-header">
		<h1 class="entry-title">Classic Reviews: Mechwarrior Dark Age by WizKids</h1>			<div class="entry-meta">
				<span class="byline"> <img class="author-photo" alt="Michael Eckenfels" src="https://secure.gravatar.com/avatar/dfae004d9ff62fb0399e674575287358?s=96&#038;d=retro&#038;r=pg" />by <span class="author vcard"><a class="url fn n" href="https://www.armchairdragoons.com/author/eckenfels/">Michael Eckenfels</a></span></span><span class="posted-on"><i class="fa fa-clock-o"></i><a href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/" rel="bookmark"><time class="entry-date published" datetime="2021-04-08T09:41:23-04:00">April 8, 2021</time><time class="updated" datetime="2021-04-08T09:44:49-04:00">April 8, 2021</time></a></span>			</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

	
		
	
	<div class="entry-content">
		<h3>Michael Eckenfels, 8 April 2021</h3>
<p>Having been a huge BattleTech nut back in the 1980&#8217;s (and owning most of the boxed sets for the game to this day), I jumped at the chance to take a look at the new miniatures battles system. What&#8217;s interesting about this one is that it is<i> not</i> the one-to-two inch metal figures that were the staple of BattleTech miniatures gaming back in the day. Instead, the figures are quite large &#8211; a &#8216;Mech is about three to four inches tall &#8211; and not just &#8216;Mechs are used to fill out an army. Infantry (powered suits and otherwise) and vehicles (sleds and tanks, to name but a few) are also available. The &#8216;Mechs resemble action figures instead of true statuesque miniatures &#8211; they rotate at the waist, and arms move up and down.</p>
<p><span id="more-8625"></span></p>
<h6 class="pullQuoteRight">On #TBT, we bring you the occasional classic article &#8211; an older review or analysis piece we wanted to rescue</h6>
<p>Included in the Starter Set is one &#8216;Mech, two vehicles, and five infantry groups. For about twenty bucks, this is kind of a sparse collection, but also included are a rules book, a cloth tape measure, dice, and various data cards with a wealth of information on various mercenary companies, people, and empires. Booster packs cost about ten dollars each and add one &#8216;Mech, one vehicle, and two infantry groups to any burgeoning military force. The unfortunate side effect, to quote a Tom Hanks character, is “you never know what you’re going to get.” The outside of the box lends no hints to what is included, which brings the game pieces into the mythological realm of collector card trading. Some of the fun in collecting cards was, indeed, not knowing what was in the pack, but with the price of these pieces, I’d much prefer to know what I’m getting. Plus, it would be nice to think, “Hey, I want a Wolverine. Where can I get one?” instead of “Hey, not another Spider.”</p>
<figure id="attachment_8630" aria-describedby="caption-attachment-8630" style="width: 550px" class="wp-caption aligncenter"><a href="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?ssl=1"><img data-attachment-id="8630" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-infantry/" data-orig-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?fit=550%2C285&amp;ssl=1" data-orig-size="550,285" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-Infantry" data-image-description data-medium-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?fit=300%2C155&amp;ssl=1" data-large-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?fit=550%2C285&amp;ssl=1" loading="lazy" class="size-full wp-image-8630 jetpack-lazy-image" src="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?resize=550%2C285&#038;ssl=1" alt="CR-MWDA-Infantry" width="550" height="285" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?w=550&amp;ssl=1 550w, https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?resize=300%2C155&amp;ssl=1 300w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?resize=550%2C285&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="8630" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-infantry/" data-orig-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?fit=550%2C285&amp;ssl=1" data-orig-size="550,285" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-Infantry" data-image-description="" data-medium-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?fit=300%2C155&amp;ssl=1" data-large-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?fit=550%2C285&amp;ssl=1" loading="lazy" class="size-full wp-image-8630" src="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?resize=550%2C285&#038;ssl=1" alt="CR-MWDA-Infantry" width="550" height="285" srcset="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?w=550&amp;ssl=1 550w, https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Infantry.png?resize=300%2C155&amp;ssl=1 300w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-8630" class="wp-caption-text">Cavalier Battle Armor. They may survive for a few more seconds than their regular Infantry cousins.</figcaption></figure>
<p>&nbsp;</p>
<p style="text-align: right; font-size: small;"><em>click images to enlarge</em></p>
<p>Games are very simple affairs, and can be played on any surface. A dedicated player could spend hundreds of dollars on a playing surface resplendent with elevations, buildings, trees, and the like, or can simply use household objects. Regardless of the playing surface, a group of two or more players can find space anywhere for a game at any time.<span class="Apple-converted-space"> </span></p>
<p>The units are finely detailed, at least a lot more so than someone like me could paint them. The good looks of the pieces combined with their action figure-like posing (for the ‘Mechs, with some vehicles able to rotate turrets) makes for some exquisite work.<span class="Apple-converted-space"> </span></p>
<figure id="attachment_8629" aria-describedby="caption-attachment-8629" style="width: 458px" class="wp-caption aligncenter"><a href="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?ssl=1"><img data-attachment-id="8629" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-hatchetman/" data-orig-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?fit=458%2C500&amp;ssl=1" data-orig-size="458,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-Hatchetman" data-image-description data-medium-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?fit=275%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?fit=458%2C500&amp;ssl=1" loading="lazy" class="size-full wp-image-8629 jetpack-lazy-image" src="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?resize=458%2C500&#038;ssl=1" alt="CR-MWDA-Hatchetman" width="458" height="500" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?w=458&amp;ssl=1 458w, https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?resize=275%2C300&amp;ssl=1 275w" data-lazy-sizes="(max-width: 458px) 100vw, 458px" data-lazy-src="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?resize=458%2C500&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="8629" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-hatchetman/" data-orig-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?fit=458%2C500&amp;ssl=1" data-orig-size="458,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-Hatchetman" data-image-description="" data-medium-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?fit=275%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?fit=458%2C500&amp;ssl=1" loading="lazy" class="size-full wp-image-8629" src="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?resize=458%2C500&#038;ssl=1" alt="CR-MWDA-Hatchetman" width="458" height="500" srcset="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?w=458&amp;ssl=1 458w, https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-Hatchetman.png?resize=275%2C300&amp;ssl=1 275w" sizes="(max-width: 458px) 100vw, 458px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-8629" class="wp-caption-text">The Hatchetman – luckily, my personal favorite ‘Mech (this one is from a Dark Age Booster Pack).</figcaption></figure>
<p>&nbsp;</p>
<p>To begin, players decide on a point limit and &#8216;buy&#8217; units from their stashes to deploy into combat. A multiple of 100 points is recommended by the game manual, and starting with 100 is a good start (but players may set it however they wish); it will purchase a &#8216;Mech, a vehicle, and a group of infantry. Set up takes place at opposite ends of a defined area (or wherever the players wish to place them, but for fairness&#8217; sake they should be some distance apart). Once set up, the players are ready for action.</p>
<p>The most innovative part of the game lay in its record keeping. Each unit has its own Combat Dial, which keeps track of various pieces of information that allows the game to be played without having to stop to consult notes or ‘Mech sheets. When a unit takes damage, the combat dial is clicked clockwise to reveal a new set of numbers, usually reflecting a slightly poorer performance (depending on the unit). The combat dial defines values such as primary damage, secondary damage, speed, attack and defense values, and so forth. ‘Mechs also have a Heat Dial, which reflects the ever-present heat buildup within the monstrous war machines. Going clockwise is called “taking a click of cooling,” while going counter-clockwise is called “taking a click of heat.” Regardless of what it’s called, it’s a nice feature.</p>
<figure id="attachment_8627" aria-describedby="caption-attachment-8627" style="width: 660px" class="wp-caption aligncenter"><a href="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?ssl=1"><img data-attachment-id="8627" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-basecloseup/" data-orig-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?fit=660%2C382&amp;ssl=1" data-orig-size="660,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-BaseCloseup" data-image-description data-medium-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?fit=300%2C174&amp;ssl=1" data-large-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?fit=660%2C382&amp;ssl=1" loading="lazy" class="size-full wp-image-8627 jetpack-lazy-image" src="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?resize=660%2C382&#038;ssl=1" alt="CR-MWDA-BaseCloseup" width="660" height="382" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?w=660&amp;ssl=1 660w, https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?resize=300%2C174&amp;ssl=1 300w" data-lazy-sizes="(max-width: 660px) 100vw, 660px" data-lazy-src="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?resize=660%2C382&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="8627" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-basecloseup/" data-orig-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?fit=660%2C382&amp;ssl=1" data-orig-size="660,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-BaseCloseup" data-image-description="" data-medium-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?fit=300%2C174&amp;ssl=1" data-large-file="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?fit=660%2C382&amp;ssl=1" loading="lazy" class="size-full wp-image-8627" src="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?resize=660%2C382&#038;ssl=1" alt="CR-MWDA-BaseCloseup" width="660" height="382" srcset="https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?w=660&amp;ssl=1 660w, https://i2.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-BaseCloseup.png?resize=300%2C174&amp;ssl=1 300w" sizes="(max-width: 660px) 100vw, 660px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-8627" class="wp-caption-text">A closer look at a ‘Mech’s base.</figcaption></figure>
<p>&nbsp;</p>
<p>Further, some units have specialties that others do not. Some, for example, have colored squares on their combat dial that are associated with special abilities related to ballistic combat, melee attacks, or defense – just to name a few. Some of these abilities, when used, are recorded by taking a click of damage. Instead of representing physical damage to the unit, the click represents ammo expenditure, used fuel, and the like. Damage then becomes a nebulous rating that encompasses not only what a player’s forces can take on the battlefield, but to an extent what they can dish out, too.</p>
<p>Orders are easily carried out. For every 100 points’ worth of force the player built up with, they receive one Order. Once their order is played, their turn ends and moves to the next player. Order choices are Move, Ranged Combat, Close Combat, or Vent. Some units are limited to the actions they can take (for example, Infantry would never need to Vent). This makes decision-making a very important factor not to be taken lightly. As the battle rages on, the player will be faced with conundrums of all types – vent the overheating ‘Mech, or fire with the tank, or…well, choices are merely limited to the extent of force the player has command over.</p>
<figure id="attachment_8628" aria-describedby="caption-attachment-8628" style="width: 660px" class="wp-caption aligncenter"><a href="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?ssl=1"><img data-attachment-id="8628" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-starterset/" data-orig-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?fit=660%2C410&amp;ssl=1" data-orig-size="660,410" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-StarterSet" data-image-description data-medium-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?fit=300%2C186&amp;ssl=1" data-large-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?fit=660%2C410&amp;ssl=1" loading="lazy" class="size-full wp-image-8628 jetpack-lazy-image" src="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?resize=660%2C410&#038;ssl=1" alt="CR-MWDA-StarterSet" width="660" height="410" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?w=660&amp;ssl=1 660w, https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?resize=300%2C186&amp;ssl=1 300w" data-lazy-sizes="(max-width: 660px) 100vw, 660px" data-lazy-src="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?resize=660%2C410&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="8628" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-starterset/" data-orig-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?fit=660%2C410&amp;ssl=1" data-orig-size="660,410" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-StarterSet" data-image-description="" data-medium-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?fit=300%2C186&amp;ssl=1" data-large-file="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?fit=660%2C410&amp;ssl=1" loading="lazy" class="size-full wp-image-8628" src="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?resize=660%2C410&#038;ssl=1" alt="CR-MWDA-StarterSet" width="660" height="410" srcset="https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?w=660&amp;ssl=1 660w, https://i0.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-StarterSet.png?resize=300%2C186&amp;ssl=1 300w" sizes="(max-width: 660px) 100vw, 660px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-8628" class="wp-caption-text">From this particular Starter Set, I have a Spider ‘Mech, an M1 Marksman Tank, a JESII Missile Carrier, and five different infantry units.</figcaption></figure>
<p>&nbsp;</p>
<p>Combat is simple and fast. When a ranged attack, for example, connects with a target it does damage equal to its Damage Value for a ranged attack. The number is how many clicks of damage the target takes. When a unit’s Combat Dial shows three bullet holes, it’s destroyed and is removed from the game (and creativity here adds some to the game, such as leaving a unit in place and adding cottonballs to represent smoke).</p>
<p>Rules regarding terrain, height advantages, speed, and even capturing enemy vehicles and ‘Mechs is included to round out an easy to learn game system. I enjoyed gaming with these pieces, although my pocketbook would require I take it in moderation. And, not knowing what’s in the boxes before paying takes me aback somewhat. However, with 116 different figures, it’s very doubtful that a casual gamer would get repeats. And to be fair, repeats aren’t necessarily bad – but like other MechWarrior players, I’m keen to certain types and loathe others.<span class="Apple-converted-space"> </span></p>
<figure id="attachment_8631" aria-describedby="caption-attachment-8631" style="width: 570px" class="wp-caption aligncenter"><a href="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?ssl=1"><img data-attachment-id="8631" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-m1marksman/" data-orig-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?fit=570%2C368&amp;ssl=1" data-orig-size="570,368" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-M1Marksman" data-image-description data-medium-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?fit=300%2C194&amp;ssl=1" data-large-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?fit=570%2C368&amp;ssl=1" loading="lazy" class="size-full wp-image-8631 jetpack-lazy-image" src="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?resize=570%2C368&#038;ssl=1" alt="CR-MWDA-M1Marksman" width="570" height="368" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?w=570&amp;ssl=1 570w, https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?resize=300%2C194&amp;ssl=1 300w" data-lazy-sizes="(max-width: 570px) 100vw, 570px" data-lazy-src="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?resize=570%2C368&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="8631" data-permalink="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/attachment/cr-mwda-m1marksman/" data-orig-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?fit=570%2C368&amp;ssl=1" data-orig-size="570,368" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CR-MWDA-M1Marksman" data-image-description="" data-medium-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?fit=300%2C194&amp;ssl=1" data-large-file="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?fit=570%2C368&amp;ssl=1" loading="lazy" class="size-full wp-image-8631" src="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?resize=570%2C368&#038;ssl=1" alt="CR-MWDA-M1Marksman" width="570" height="368" srcset="https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?w=570&amp;ssl=1 570w, https://i1.wp.com/www.armchairdragoons.com/wp-content/uploads/2021/03/CR-MWDA-M1Marksman.png?resize=300%2C194&amp;ssl=1 300w" sizes="(max-width: 570px) 100vw, 570px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-8631" class="wp-caption-text">M1 Marksman tank, again, with the quarter for scale</figcaption></figure>
<p>&nbsp;</p>
<p>And, a game with anything more than a dozen units to each side can be a bit unwieldy, given the one-turn-per-100-points turn system. Such battles would last a long, long time that begs the question that this game was intended more to be fought as small-unit actions instead of representing huge campaigns – although with enough time and units, any battle from the MechWarrior universe should be playable.</p>
<p>This game is worthy of any MechWarrior fan’s collection, at the very least with a Starter Set and a Booster Pack. With like-minded and like-equipped friends, an evening of ‘Mech warfare is easy, manageable, and most of all, fun.</p>
<p>&nbsp;</p>
<hr />
<p>Thank you for visiting <span style="color: #800000;"><strong>The Armchair Dragoons</strong></span> and spending some time with the Regiment of Strategy Gaming.<br />
You can find the regiment&#8217;s social media on <a href="https://www.facebook.com/Armchair-Dragoons-462506274241872/">Facebook</a>, <a href="https://twitter.com/ADragoons">Twitter</a>, and <a href="https://www.youtube.com/channel/UCJnWABRqXg1Eiteb36WJfew">YouTube</a>, and occasionally at a convention near you.<br />
We also have <a href="http://www.patreon.com/armchairdragoons/">our Patreon</a>, where supporter can help us keep The Armchair Dragoons on the web, and on the podcast.<br />
We welcome your feedback either in our <a href="https://www.armchairdragoons.com/forum/">discussion forum</a>, or in the comment area below.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-8625" class="share-twitter sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-8625" class="share-facebook sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-8625" class="share-linkedin sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-8625" class="share-pinterest sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.armchairdragoons.com/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-151118971-8625-606f884fe16f2' data-src='https://widgets.wp.com/likes/#blog_id=151118971&amp;post_id=8625&amp;origin=www.armchairdragoons.com&amp;obj_id=151118971-8625-606f884fe16f2' data-name='like-post-frame-151118971-8625-606f884fe16f2'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		<div class="tags-links"><span class="bam-tags-title">Tagged</span><a href="https://www.armchairdragoons.com/tag/classic-reviews/" rel="tag">Classic Reviews</a></div>	</footer><!-- .entry-footer -->
</article><!-- #post-8625 -->
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.armchairdragoons.com/feature/my-own-worst-enemy-the-great-crisis-of-frederick-ii-part-5/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous Post</span> <span class="screen-reader-text">Previous post:</span> <br/><span class="post-title">My Own Worst Enemy ~ The Great Crisis of Frederick II Part 5</span></a></div></div>
	</nav><div class="bam-authorbox clearfix">

    <div class="bam-author-img">
        <img alt src="https://secure.gravatar.com/avatar/dfae004d9ff62fb0399e674575287358?s=100&#038;d=retro&#038;r=pg" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/dfae004d9ff62fb0399e674575287358?s=200&#038;d=retro&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/dfae004d9ff62fb0399e674575287358?s=100&amp;is-pending-load=1#038;d=retro&#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/dfae004d9ff62fb0399e674575287358?s=100&#038;d=retro&#038;r=pg' srcset='https://secure.gravatar.com/avatar/dfae004d9ff62fb0399e674575287358?s=200&#038;d=retro&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/></noscript>    </div>

    <div class="bam-author-content">
        <h4 class="author-name">Michael Eckenfels</h4>
        <p class="author-description"></p>
        <a class="author-posts-link" href="https://www.armchairdragoons.com/author/eckenfels/" title="Michael Eckenfels">
            View all posts by Michael Eckenfels &rarr;        </a>
    </div>

</div>
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Tell us what you think!					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/articles/reviews/classic-reviews-mechwarrior-dark-age-by-wizkids/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=151118971&#038;postid=8625&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Tell+us+what+you+think%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.6&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=82d7d17dc8f33deb50237e53be08beac01582589#parent=https%3A%2F%2Fwww.armchairdragoons.com%2Farticles%2Freviews%2Fclassic-reviews-mechwarrior-dark-age-by-wizkids%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->

			
		</main><!-- #main -->

		
	</div><!-- #primary -->

	


<aside id="secondary" class="widget-area">

	
	<section id="fergcorp_countdown_timer_widget-3" class="widget widget_fergcorp_countdown_timer_widget"><h4 class="widget-title">Armchair Dragoons Upcoming Expeditions</h4><ul><li class = 'fergcorp_countdownTimer_event_li'><span class = 'fergcorp_countdownTimer_event_title'>Connections Online</span>:<br />
<abbr title = "April 12th, 2021, 8:00 am" id = 'x1262df1c528fc86175e443718b75ded7' class = 'fergcorp_countdownTimer_event_time'>in <span class="fergcorp_countdownTimer_day fergcorp_countdownTimer_timeUnit">3 days,</span> <span class="fergcorp_countdownTimer_hour fergcorp_countdownTimer_timeUnit">13 hours</span></abbr></li>
<li class = 'fergcorp_countdownTimer_event_li'><span class = 'fergcorp_countdownTimer_event_title'>The Summer ACDC</span>:<br />
<abbr title = "June 18th, 2021, 1:00 pm" id = 'xacabcfc4fe72e463c741a45f0bee6c94' class = 'fergcorp_countdownTimer_event_time'>in <span class="fergcorp_countdownTimer_month fergcorp_countdownTimer_timeUnit">2 months,</span> <span class="fergcorp_countdownTimer_day fergcorp_countdownTimer_timeUnit">9 days,</span> <span class="fergcorp_countdownTimer_hour fergcorp_countdownTimer_timeUnit">18 hours</span></abbr></li>
<li class = 'fergcorp_countdownTimer_event_li'><span class = 'fergcorp_countdownTimer_event_title'><a href="www.originsgamefair.com" class = 'fergcorp_countdownTimer_event_linkTitle'>Origins Game Fair 2021</a></span>:<br />
<abbr title = "September 30th, 2021, 8:00 am" id = 'xf54220a0d1b48e6bc6d3681a4768052c' class = 'fergcorp_countdownTimer_event_time'>in <span class="fergcorp_countdownTimer_month fergcorp_countdownTimer_timeUnit">5 months,</span> <span class="fergcorp_countdownTimer_day fergcorp_countdownTimer_timeUnit">21 days,</span> <span class="fergcorp_countdownTimer_hour fergcorp_countdownTimer_timeUnit">13 hours</span></abbr></li>
</ul></section>		<section id="recent-podcast-episodes-2" class="widget widget_recent_entries widget_recent_episodes">		<h4 class="widget-title">Latest Podcast Episodes</h4>		<ul>
					<li>
				<a href="https://www.armchairdragoons.com/podcast/mentioned-in-dispatches-season-6-ep-10-andrew-bucholtz/">Mentioned In Dispatches &#8211; Season 6 Ep 10 &#8211; Andrew Bucholtz</a>
							<span class="post-date">April 2, 2021</span>
						</li>
					<li>
				<a href="https://www.armchairdragoons.com/podcast/mentioned-in-dispatches-season-6-ep-9-connections-online/">Mentioned In Dispatches &#8211; Season 6 Ep 9 &#8211; Connections Online!</a>
							<span class="post-date">March 26, 2021</span>
						</li>
					<li>
				<a href="https://www.armchairdragoons.com/podcast/mentioned-in-dispatches-season-6-ep-8-the-annual-bison-migration/">Mentioned In Dispatches &#8211; Season 6 Ep 8 &#8211; The Annual Bison Migration</a>
							<span class="post-date">March 19, 2021</span>
						</li>
				</ul>
		</section><section id="search-2" class="widget widget_search"><h4 class="widget-title">Search the Site</h4><form role="search" method="get" class="search-form" action="https://www.armchairdragoons.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><h4 class="widget-title">Our RSS Feeds</h4><div class="textwidget custom-html-widget"><ul>
<li><a href='https://www.armchairdragoons.com/feed/podcast'>Mentioned in Dispatches</a></li>
	<li><a href='http://www.armchairdragoons.com/feed/'>Our Article Feed</a></li>
<li><a href='https://www.youtube.com/watch?v=AfkxTCCCEFo&list=PLnTxkmKEim-PPOIWO5Gp2MxHGxDH0Hbfc'>Saturday Night Fights</a></li>
</ul></div></section><section id="categories-2" class="widget widget_categories"><h4 class="widget-title">Categories</h4>
			<ul>
					<li class="cat-item cat-item-13"><a href="https://www.armchairdragoons.com/category/articles/aars/" title="Watch the game unfold">After-Action Reports</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://www.armchairdragoons.com/category/articles/analysis/" title="Digging under the hood">Analysis</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://www.armchairdragoons.com/category/articles/" title="Non-feature articles">Articles</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://www.armchairdragoons.com/category/articles/columns/" title="Personal columns">Columns</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://www.armchairdragoons.com/category/events/cons/" title="Conventions">Conventions</a>
</li>
	<li class="cat-item cat-item-29"><a href="https://www.armchairdragoons.com/category/articles/design/" title="Game design discussion">Design</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://www.armchairdragoons.com/category/events/" title="Real-world reports">Events</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://www.armchairdragoons.com/category/feature/" title="Feature articles">Features</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://www.armchairdragoons.com/category/events/sites/" title="Visits to battlefields and other key historical sites">Historical Sites</a>
</li>
	<li class="cat-item cat-item-18"><a href="https://www.armchairdragoons.com/category/articles/interviews/">Interviews</a>
</li>
	<li class="cat-item cat-item-35"><a href="https://www.armchairdragoons.com/category/articles/wenemy/" title="My Own Worst Enemy video series">My Own Worst Enemy</a>
</li>
	<li class="cat-item cat-item-12"><a href="https://www.armchairdragoons.com/category/news/" title="Industry News &amp; Reports">News</a>
</li>
	<li class="cat-item cat-item-28"><a href="https://www.armchairdragoons.com/category/partners/" title="Content from partner sites">Partners</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://www.armchairdragoons.com/category/articles/research/" title="Digging into the hobby">Research</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://www.armchairdragoons.com/category/articles/reviews/" title="Reviews of games">Reviews</a>
</li>
	<li class="cat-item cat-item-32"><a href="https://www.armchairdragoons.com/category/articles/reviews/unbox/">Unboxing</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://www.armchairdragoons.com/category/events/wn/" title="Reports from Wargaming Night Across the Hobby">Wargame Night</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://www.armchairdragoons.com/category/whatever/">Whatever</a>
</li>
			</ul>

			</section>
	
</aside><!-- #secondary -->

	</div><!-- .container -->
	</div><!-- #content -->

	
	
	<footer id="colophon" class="site-footer">

		
		
		<div class="footer-widget-area clearfix th-columns-3">
			<div class="container">
				<div class="footer-widget-area-inner">
					<div class="col column-1">
											</div>

											<div class="col column-2">
													</div>
					
											<div class="col column-3">
													</div>
					
									</div><!-- .footer-widget-area-inner -->
			</div><!-- .container -->
		</div><!-- .footer-widget-area -->

		<div class="site-info clearfix">
			<div class="container">
				<div class="copyright-container">
					© 2018-2021 Armchair Dragoons ~~
Best community on the internet... ~~
					Powered by <a href="https://wordpress.org" target="_blank">WordPress</a> and <a href="https://themezhut.com/themes/bam/" target="_blank">Bam</a>.				</div><!-- .copyright-container -->
			</div><!-- .container -->
		</div><!-- .site-info -->

		
	</footer><!-- #colophon -->

	
</div><!-- #page -->


    <script>
        function coolTagCloudToggle( element ) {
            var parent = element.closest('.cool-tag-cloud');
            parent.querySelector('.cool-tag-cloud-inner').classList.toggle('cool-tag-cloud-active');
            parent.querySelector( '.cool-tag-cloud-load-more').classList.toggle('cool-tag-cloud-active');
        }
    </script>
    <!-- YouTube Feed JS -->
<script type="text/javascript">

</script>
	<div style="display:none">
	<div class="grofile-hash-map-dfae004d9ff62fb0399e674575287358">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.armchairdragoons.com\/articles\/reviews\/classic-reviews-mechwarrior-dark-age-by-wizkids\/":8625};
	</script>
						<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202114' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.6' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/themes/bamChild/assets/js/scripts.js?ver=5.6.2' id='bam-scripts-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/themes/bamChild/assets/js/main-navigation.js?ver=5.6.2' id='bam-main-navigation-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/themes/bamChild/assets/js/skip-link-focus-fix.js?ver=20151215' id='bam-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/themes/bamChild/assets/js/jquery.fitvids.js?ver=5.6.2' id='jquery-fitvids-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='fergcorp_countdowntimer-js-extra'>
/* <![CDATA[ */
var fergcorp_countdown_timer_js_lang = {"year":"%d year,","years":"%d years,","month":"%d month,","months":"%d months,","week":"%d week,","weeks":"%d weeks,","day":"%d day,","days":"%d days,","hour":"%d hour,","hours":"%d hours,","minute":"%d minute,","minutes":"%d minutes,","second":"%d second,","seconds":"%d seconds,","agotime":"%s ago","intime":"in %s"};
var fergcorp_countdown_timer_jsEvents = {"x1262df1c528fc86175e443718b75ded7":"1618228800","xacabcfc4fe72e463c741a45f0bee6c94":"1624035600","xf54220a0d1b48e6bc6d3681a4768052c":"1633003200"};
var fergcorp_countdown_timer_options = {"showYear":"1","showMonth":"1","showWeek":"0","showDay":"1","showHour":"1","showMinute":"0","showSecond":"0","stripZero":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/countdown-timer/js/fergcorp_countdownTimer_java.js?ver=3.0.7' id='fergcorp_countdowntimer-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.armchairdragoons.com\/wp-admin\/admin-ajax.php","nonce":"c0fa14b92c","display_exif":"0","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.armchairdragoons.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.armchairdragoons.com%2Farticles%2Freviews%2Fclassic-reviews-mechwarrior-dark-age-by-wizkids%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=9.6' id='jetpack-carousel-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=9.6' id='postmessage-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=9.6' id='jetpack_resize-js'></script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=9.6' id='jetpack_likes_queuehandler-js'></script>
<script async="async" type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.armchairdragoons.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.6' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-telegram' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-telegram' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-tumblr' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-tumblr' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202114#ver=202114' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=151118971&postid=8625&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Tell+us+what+you+think%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=82d7d17dc8f33deb50237e53be08beac01582589#parent=https%3A%2F%2Fwww.armchairdragoons.com%2Farticles%2Freviews%2Fclassic-reviews-mechwarrior-dark-age-by-wizkids%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=151118971&postid=8625&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Tell+us+what+you+think%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=82d7d17dc8f33deb50237e53be08beac01582589#parent=https%3A%2F%2Fwww.armchairdragoons.com%2Farticles%2Freviews%2Fclassic-reviews-mechwarrior-dark-age-by-wizkids%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202114.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6',blog:'151118971',post:'8625',tz:'-4',srv:'www.armchairdragoons.com'} ]);
	_stq.push([ 'clickTrackerInit', '151118971', '8625' ]);
</script>
</body>
</html>